Categories

See More
Popular Forum

MBA (4887) B.Tech (1769) Engineering (1486) Class 12 (1030) Study Abroad (1004) Computer Science and Engineering (988) Business Management Studies (865) BBA (846) Diploma (746) CAT (651) B.Com (648) B.Sc (643) JEE Mains (618) Mechanical Engineering (574) Exam (525) India (462) Career (452) All Time Q&A (439) Mass Communication (427) BCA (417) Science (384) Computers & IT (Non-Engg) (383) Medicine & Health Sciences (381) Hotel Management (373) Civil Engineering (353) MCA (349) Tuteehub Top Questions (348) Distance (340) Colleges in India (334)
See More

Conan: Command Not Found

General Tech Bugs & Fixes
Max. 2000 characters
Replies

usr_profile.png
Nicola Aley

User

( 7 months ago )

 

I'm using a RPI 3B

uname -a returns: 4.14.98-v7+ #1200 armv71

OS is stretch

gcc version is 4.9.3

I'm attempting to setup my RPi to be a BLE gateway as per this project on hackster.io. I executed the first few commands:

git clone --recurse-submodules https://github.com/Wolkabout/WolkGateway.git

sudo apt-get install mosquitto cmake python python-pip && python -m pip install conan

The Bash Script

then I ran a bash script (configure.sh) that contains the following:

!/usr/bin/env bash

cp tools/git/pre-commit .git/hooks/pre-commit
chmod +x .git/hooks/pre-commit

pushd out
conan install -s compiler.libcxx=libstdc++11 --build=missing ..
cmake -G "Unix Makefiles" -DCMAKE_BUILD_TYPE=Release ..
popd

The Output of the Bash Script

the terminal outputs:

line 21: conan: command not found

line 21 is the line with conan.

Then I get a CMake error:

CMakeLists.txt:(20) (include):
include could not find load file:
/home/pi/Wolk...conanbuildinfo.cmake

Maybe Conan Isn't in My PATH

My thought was that the command conan isn't in my $PATH so I checked PIP:

pip show conan

this gave me the location of conan:

/home/pi/.local/lib/python2.7/site-packages

I then added that path to my $PATH:

export PATH=$PATH:/home/pi/.local/lib/python2.7/site-packages

This didn't work, causing the same error when re-running the aforementioned bash script (configure.sh)

Installing Conan From Source

I went here and installed conan from source:

 git clone https://github.com/conan-io/conan.git
 cd conan
 pip install -r conans/requirements.txt

The Python Script to Add Conan to my PATH

#!/usr/bin/env python

import sys

conan_repo_path = "/home/pi/conan" # ABSOLUTE PATH TO CONAN 
REPOSITORY FOLDER

sys.path.append(conan_repo_path)
from conans.client.command import main
main(sys.argv
								
usr_profile.png
Bhanu Gupta

User

( 7 months ago )

 

When installing conan:

sudo apt-get install mosquitto cmake python python-pip && python -m pip install conan

the later half:

python -m pip install conan

should be installed using sudo:

sudo python -m pip install conan

If this doesn't work, try uninstalling conan:

pip uninstall conan

and then reinstall:

sudo pip install conan

Currently my RPi is running the configure.sh script successfully.

what's your interest