Categories

See More
Popular Forum

MBA (4887) B.Tech (1769) Engineering (1486) Class 12 (1030) Study Abroad (1004) Computer Science and Engineering (988) Business Management Studies (865) BBA (846) Diploma (746) CAT (651) B.Com (648) B.Sc (643) JEE Mains (618) Mechanical Engineering (574) Exam (525) India (462) Career (452) All Time Q&A (439) Mass Communication (427) BCA (417) Science (384) Computers & IT (Non-Engg) (383) Medicine & Health Sciences (381) Hotel Management (373) Civil Engineering (353) MCA (349) Tuteehub Top Questions (348) Distance (340) Colleges in India (334)
See More

Failed installation of salesforce-mc/fuel-sdk-php via composer

General Tech Bugs & Fixes

Max. 2000 characters
Replies

usr_profile.png

User

( 5 months ago )

 

I'm new to SDK-PHP and stuck on installing it via composer. I am currently using WAMP server 3.1.0 for Windows 10 which has 3 versions of PHP included. As documentation said version 5.6.24 is required for SDK-PHP. So I tried available 5.6.31 and got this from composer

composer require salesforce-mc/fuel-sdk-php
Using version ^1.1 for salesforce-mc/fuel-sdk-php
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - doctrine/annotations v1.6.0 requires php ^7.1 -> your PHP version (5.6.31) does not satisfy that requirement.
    - doctrine/annotations v1.6.0 requires php ^7.1 -> your PHP version (5.6.31) does not satisfy that requirement.
    - doctrine/annotations v1.6.0 requires php ^7.1 -> your PHP version (5.6.31) does not satisfy that requirement.
    - Installation request for doctrine/annotations (locked at v1.6.0) -> satisfiable by doctrine/annotations[v1.6.0]. 
Installation failed, reverting ./composer.json to its original content.

Then I changed PHP version to available 7.1.9 but that was not successful as well

composer  require salesforce-mc/fuel-sdk-php

 Using version ^1.1 for salesforce-mc/fuel-sdk-php
 ./composer.json has been updated
 Loading composer repositories with package information
 Updating dependencies (including require-dev)
 Your requirements could not be resolved to an installable set of packages.

   Problem 1
     - Installation request for salesforce-mc/fuel-sdk-php dev-master -> satisfiable by salesforce-mc/fuel-sdk-php[dev-master].
     - Can only install one of: salesforce-mc/fuel-sdk-php[v1.1.0, dev-master].
     - Installation request for salesforce-mc/fuel-sdk-php ^1.1 -> satisfiable by salesforce-mc/fuel-sdk-php[v1.1.0].
 Installation failed, reverting ./composer.json to its original content.

Would anyone be able to help resolving this issue?

usr_profile.png

User

( 5 months ago )

Not sure whether I understand situation correctly. So if you mention ours as a require in composer.json like below:

{ "require": { "salesforce-mc/fuel-sdk-php": "1.1.0" } }

Then all you need to do is run this:

$ composer update

So if you download our source code from github, then we dont need to add this in the require section:

"salesforce-mc/fuel-sdk-php": "1.1.0" which is only necessary when you dont download the source code and want to get it from composer where we already released as a package.

So just to be clear, if you download our source code from github, all you should need to do is this:

$ composer update --no-dev

which will download all the dependencies mentioned in our composer.json file and ignore the require-dev section.

what's your interest


forum_ban8_5d8c5fd7cf6f7.gif