Categories

See More
Popular Forum

MBA (4887) B.Tech (1769) Engineering (1486) Class 12 (1030) Study Abroad (1004) Computer Science and Engineering (988) Business Management Studies (865) BBA (846) Diploma (746) CAT (651) B.Com (648) B.Sc (643) JEE Mains (618) Mechanical Engineering (574) Exam (525) India (462) Career (452) All Time Q&A (439) Mass Communication (427) BCA (417) Science (384) Computers & IT (Non-Engg) (383) Medicine & Health Sciences (381) Hotel Management (373) Civil Engineering (353) MCA (349) Tuteehub Top Questions (348) Distance (340) Colleges in India (334)
See More

install php-fpm on centos after remoe it

General Tech Bugs & Fixes

Max. 2000 characters
Replies

usr_profile.png

User

( 5 months ago )

 

i install php-fpm and php-mysql and nginx then i remove it and update servers kernel. now, when i want to install php-fpm ,.. dont install

$>uname -a
2.6.32-504.3.3.el6.x86_64 #1 SMP Wed Dec 17 01:55:02 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

$>yum --enablerepo=remi install php php-fpm php-common php-gd php-mysql

Error: Package: php-5.4.37-1.el7.remi.x86_64 (remi)
           Requires: httpd-mmn = 20120211x8664
           Installing: httpd-2.2.15-39.el6.centos.x86_64 (base)
               httpd-mmn = 20051115
Error: Package: php-fpm-5.4.37-1.el7.remi.x86_64 (remi)
           Requires: libsystemd-daemon.so.0()(64bit)
Error: Package: php-5.4.37-1.el7.remi.x86_64 (remi)
           Requires: libxml2.so.2(LIBXML2_2.9.0)(64bit)
Error: Package: php-mysql-5.4.37-1.el7.remi.x86_64 (remi)
           Requires: php-pdo(x86-64) = 5.4.37-1.el7.remi
           Installed: php-pdo-5.5.20-2.el6.remi.x86_64 (@remi-php55)
               php-pdo(x86-64) = 5.5.20-2.el6.remi
           Available: php-pdo-5.3.3-38.el6.x86_64 (base)
               php-pdo(x86-64) = 5.3.3-38.el6
           Available: php-pdo-5.3.3-40.el6_6.x86_64 (updates)
               php-pdo(x86-64) = 5.3.3-40.el6_6
           Available: php-pdo-5.4.36-1.el7.remi.x86_64 (remi)
               php-pdo(x86-64) = 5.4.36-1.el7.remi
           Available: php-pdo-5.4.37-1.el7.remi.x86_64 (remi)
               php-pdo(x86-64) = 5.4.37-1.el7.remi
           Available: php54w-pdo-5.4.36-1.w6.x86_64 (webtatic)
               php-pdo(x86-64) = 5.4.36-1.w6
           Available: php55w-pdo-5.5.20-1.w6.x86_64 (webtatic)
               php-pdo(x86-64) = 5.5.20-1.w6
           Available: php56w-pdo-5.6.4-1.w6.x86_64 (webtatic)
               php-pdo(x86-64) = 5.6.4-1.w6
Error: Package: php-fpm-5.4.37-1.el7.remi.x86_64 (remi)
           Requires: systemd-units
Error: Package: php-mysql-5.4.37-1.el7.remi.x86_64 (remi)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: php-fpm-5.4.37-1.el7.remi.x86_64 (remi)
           Requires: libpcre.so.1()(64bit)
Error: Package: php-5.4.37-1.el7.remi.x86_64 (remi)
           Requires: libpcre.so.1()(64bit)
Error: Package: php-fpm-5.4.37-1.el7.remi.x86_64 (remi)
           Requires: libc.so.6(GLIBC_2.15)(64bit)
Error: Package: php-5.4.37-1.el7.remi.x86_64 (remi)
           Requires: httpd-mmn = 20120211x8664
           Available: httpd-2.2.15-39.el6.centos.x86_64 (base)
               httpd-mmn = 20051115
Error: Package: php-5.4.37-1.el7.remi.x86_64 (remi)
           Requires: php-cli(x86-64) = 5.4.37-1.el7.remi
           Installed: php-cli-5.5.20-2.el6.remi.x86_64 (@remi-php55)
               php-cli(x86-64) = 5.5.20-2.el6.remi
           Available: php-cli-5.3.3-38.el6.x86_64 (base)
               php-cli(x86-64) = 5.3.3-38.el6
           Available: php-cli-5.3.3-40.el6_6.x86_64 (updates)
               php-cli(x86-64) = 5.3.3-40.el6_6
           Available: php-cli-5.4.36-1.el7.remi.x86_64 (remi)
               php-cli(x86-64) = 5.4.36-1.el7.remi
           Available: php-cli-5.4.37-1.el7.remi.x86_64 (remi)
               php-cli(x86-64) = 5.4.37-1.el7.remi
           Available: php54w-cli-5.4.36-1.w6.x86_64 (webtatic)
               php-cli(x86-64) = 5.4.36-1.w6
           Available: php55w-cli-5.5.20-1.w6.x86_64 (webtatic)
               php-cli(x86-64) = 5.5.20-1.w6
           Available: php56w-cli-5.6.4-1.w6.x86_64 (webtatic)
               php-cli(x86-64) = 5.6.4-1.w6
Error: Package: php-5.4.37-1.el7.remi.x86_64 (remi)
           Requires: libc.so.6(GLIBC_2.15)(64bit)
Error: Package: php-5.4.37-1.el7.remi.x86_64 (remi)
           Requires: php-common(x86-64) = 5.4.37-1.el7.remi
           Installed: php-common-5.5.20-2.el6.remi.x86_64 (@remi-php55)
               php-common(x86-64) = 5.5.20-2.el6.remi
           Available: php-common-5.3.3-38.el6.x86_64 (base)
               php-common(x86-64) = 5.3.3-38.el6
           Available: php-common-5.3.3-40.el6_6.x86_64 (updates)
               php-common(x86-64) = 5.3.3-40.el6_6
           Available: php-common-5.4.36-1.el7.remi.x86_64 (remi)
               php-common(x86-64) = 5.4.36-1.el7.remi
           Available: php-common-5.4.37-1.el7.remi.x86_64 (remi)
               php-common(x86-64) = 5.4.37-1.el7.remi
           Available: php54w-common-5.4.36-1.w6.x86_64 (webtatic)
               php-common(x86-64) = 5.4.36-1.w6
           Available: php55w-common-5.5.20-1.w6.x86_64 (webtatic)
               php-common(x86-64) = 5.5.20-1.w6
           Available: php56w-common-5.6.4-1.w6.x86_64 (webtatic)
               php-common(x86-64) = 5.6.4-1.w6
Error: Package: php-fpm-5.4.37-1.el7.remi.x86_64 (remi)
           Requires: systemd-sysv
Error: Package: php-fpm-5.4.37-1.el7.remi.x86_64 (remi)
           Requires: libxml2.so.2(LIBXML2_2.9.0)(64bit)
Error: Package: php-fpm-5.4.37-1.el7.remi.x86_64 (remi)
           Requires: libsystemd-daemon.so.0(LIBSYSTEMD_DAEMON_31)(64bit)
Error: Package: php-fpm-5.4.37-1.el7.remi.x86_64 (remi)
           Requires: php-common(x86-64) = 5.4.37-1.el7.remi
           Installed: php-common-5.5.20-2.el6.remi.x86_64 (@remi-php55)
               php-common(x86-64) = 5.5.20-2.el6.remi
           Available: php-common-5.3.3-38.el6.x86_64 (base)
               php-common(x86-64) = 5.3.3-38.el6
           Available: php-common-5.3.3-40.el6_6.x86_64 (updates)
               php-common(x86-64) = 5.3.3-40.el6_6
           Available: php-common-5.4.36-1.el7.remi.x86_64 (remi)
               php-common(x86-64) = 5.4.36-1.el7.remi
           Available: php-common-5.4.37-1.el7.remi.x86_64 (remi)
               php-common(x86-64) = 5.4.37-1.el7.remi
           Available: php54w-common-5.4.36-1.w6.x86_64 (webtatic)
               php-common(x86-64) = 5.4.36-1.w6
           Available: php55w-common-5.5.20-1.w6.x86_64 (webtatic)
               php-common(x86-64) = 5.5.20-1.w6
           Available: php56w-common-5.6.4-1.w6.x86_64 (webtatic)
               php-common(x86-64) = 5.6.4-1.w6

what am i doing :(((( ?

usr_profile.png

User

( 5 months ago )

Please remove the remi repository from your machine/server. After that you add this repository.

Then try to install with

yum --enablerepo=remi install php php-fpm php-common php-gd php-mysql

wget http://dl.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm

sudo rpm -Uvh epel-release-6*.rpm

what's your interest


forum_ban8_5d8c5fd7cf6f7.gif