Categories

See More
Popular Forum

MBA (4887) B.Tech (1769) Engineering (1486) Class 12 (1030) Study Abroad (1004) Computer Science and Engineering (988) Business Management Studies (865) BBA (846) Diploma (746) CAT (651) B.Com (648) B.Sc (643) JEE Mains (618) Mechanical Engineering (574) Exam (525) India (462) Career (452) All Time Q&A (439) Mass Communication (427) BCA (417) Science (384) Computers & IT (Non-Engg) (383) Medicine & Health Sciences (381) Hotel Management (373) Civil Engineering (353) MCA (349) Tuteehub Top Questions (348) Distance (340) Colleges in India (334)
See More

Node-gyp (or gyp) action targets containing =, & on Linux

General Tech Bugs & Fixes
Max. 2000 characters
Replies

usr_profile.png
James Watson

User

( 9 months ago )

I'm using node-gyp on Linux with and need to use actions to define custom build steps (note sure whether this is a node-gyp issue or a general gyp issue).

The documentation seems to suggest that you should specify the command for the build steps as an array of strings, which must get concatenated together at some point to form the command:

'action': ['python', 'tools/js2c.py', '<@(_outputs)', 'CORE', '<@(core_library_files)'],

As it's Linux, node-gyp is going to generate a makefile for each target in the binding.gyp file, and for actions the custom command will appear in that makefile.

The problem I'm having is that the command needs to contain an = sign to set an environment variable as part of the command, and I need to chain commands with &&, e.g.:

export FOO=BAR && do-something-else --option

If I try to specify that as a gyp actions step, I hit various problems. I tried adding each 'word' in the command as a separate array element.

'action': ['export', 'FOO=BAR', '&&', 'do-something-else', '--option'],

That doesn't work, gyp (or rather the shell the command is passed to) complains that '&&' is not a valid identifier.

Peeking into the generated makefile, the command has been expanded to this, which explains the shell error:

export "FOO=BAR" "&&" do-something-else --option

The quotes have been left around the variable assignment and the &&. It's not clear why. I've tried many variations to stop this from happening to no avail. Anything that contains = or & ends up with quotes left around it, which in most cases renders the command syntax invalid.

Suggestions appreciated.

usr_profile.png
Mike Franklin

User

( 9 months ago )

The reason this happens is that Gyp considers everything after the first word to be an argument to the command given in the first word so it quotes these and other special characters to prevent the shell interpreting them. I do not think there is any way to prevent it which, as you discovered, makes creating a custom command using a pipeline of shell commands well nigh impossible.

 

what's your interest


forum_ban8_5d8c5fd7cf6f7.gif