Categories

See More
Popular Forum

MBA (4887) B.Tech (1769) Engineering (1486) Class 12 (1030) Study Abroad (1004) Computer Science and Engineering (988) Business Management Studies (865) BBA (846) Diploma (746) CAT (651) B.Com (648) B.Sc (643) JEE Mains (618) Mechanical Engineering (574) Exam (525) India (462) Career (452) All Time Q&A (439) Mass Communication (427) BCA (417) Science (384) Computers & IT (Non-Engg) (383) Medicine & Health Sciences (381) Hotel Management (373) Civil Engineering (353) MCA (349) Tuteehub Top Questions (348) Distance (340) Colleges in India (334)
See More

PHP / Extension API mismatch

General Tech Bugs & Fixes

Max. 2000 characters
Tuteehub
Replies

usr_profile.png

User

( 6 months ago )

I recently upgraded to Apache 2.4.7 (x86) and PHP 5.5.9 (x86 as Apache module) on Windows 7 x64. I downloaded the Apache binary from apachelounge.com and the PHP binary from windows.php.net.

Now the error logs keep telling me that the PHP build API and certain extension APIs (php_fileinfo.dll for instance) are mismatched. I downgraded back to Apache 2.2.22 and PHP 5.3.6, using the original MSI's I previously installed them with, and I have the same problem!

Does anyone know what has caused this?

usr_profile.png

User

( 6 months ago )

I would hazard a guess that you either did not properly uninstall the previous versions.

OR

You have at some stage copied something from either Apache or PHP into somewhere like C:\windows\system32 or something like that and whatever that was was not removed when you uninstalled the previous versions, and it is that that is causing the problems.

OR

You have something added to your PATH and did not chnage it.

It should not be necessary to copy anything to the Windows folder or have anything hardcoded onto your PATH.

 

what's your interest


forum_ban8_5d8c5fd7cf6f7.gif