Categories

See More
Popular Forum

MBA (4887) B.Tech (1769) Engineering (1486) Class 12 (1030) Study Abroad (1004) Computer Science and Engineering (988) Business Management Studies (865) BBA (846) Diploma (746) CAT (651) B.Com (648) B.Sc (643) JEE Mains (618) Mechanical Engineering (574) Exam (525) India (462) Career (452) All Time Q&A (439) Mass Communication (427) BCA (417) Science (384) Computers & IT (Non-Engg) (383) Medicine & Health Sciences (381) Hotel Management (373) Civil Engineering (353) MCA (349) Tuteehub Top Questions (348) Distance (340) Colleges in India (334)
See More

PHP Package installation error

General Tech Bugs & Fixes
Max. 2000 characters
Replies

usr_profile.png
Sophia Chang

User

( 7 months ago )

When I install PHP this error occurs:

Package 'php5-gd' has no installation candidate  

Additional output:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package php5-mysql is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or is only available from another source

E: Package 'php5-mysql' has no installation candidate

How can I fix this problem?

usr_profile.png
Sophia Chang

User

( 7 months ago )

The solution is easy:

sudo apt-get install php-gd php-mysql

16.04 LTS comes now with php 7.0 and the names of the whole packages including the virtual packages have changed to be now php-* or php7.0-* instead of php5-*.

what's your interest


forum_ban8_5d8c5fd7cf6f7.gif