Categories

See More
Popular Forum

MBA (4887) B.Tech (1769) Engineering (1486) Class 12 (1030) Study Abroad (1004) Computer Science and Engineering (988) Business Management Studies (865) BBA (846) Diploma (746) CAT (651) B.Com (648) B.Sc (643) JEE Mains (618) Mechanical Engineering (574) Exam (525) India (462) Career (452) All Time Q&A (439) Mass Communication (427) BCA (417) Science (384) Computers & IT (Non-Engg) (383) Medicine & Health Sciences (381) Hotel Management (373) Civil Engineering (353) MCA (349) Tuteehub Top Questions (348) Distance (340) Colleges in India (334)
See More

Suggestions on investigating a failure with writing RAW data to a USB drive

General Tech Bugs & Fixes

Max. 2000 characters
Replies

usr_profile.png

User

( 6 months ago )

 

I have a 16GB USB drive from SanDisk (Cruzer Glide). I've purchased these before and had great success with them. The ones I bought previously had an amber LED. The new ones I bought have a blue LED. There are numbers on the back which differ between drives but the model itself is the same: SDCZ60-016G.

I noticed a problem today when trying to write a Linux image to the disk using a RAW write and having it either fail to verify during the pre-installation test or completely fail or boot. I tried several write attempts on two of these new blue LED drives and they all failed to verify.

The drives appear to be genuine and have passed a complete write and verify by h2testw, which I've used in the past to determine if an SD card is counterfeit. The test wrote and verified the entire disk without problem.

To confirm writing to the disk, I copied the Linux ISO I downloaded (1.5G), verified the sha256 hash locally, copied it to the USB disk, and verified it again there. Files are copying fine when done so on a formatted disk but appear to be failing when performing a RAW write.

I tried to write this ISO using UltraISO (Bootable -> Write Disk Image...) and Win32 Disk Imager. Both would write as RAW but failed to verify.

What can I do to further investigate what is being written to the disk to try and identify the problem?

I have been writing these images from Windows 10 x64 but have access and experience with Linux. So any suggestions on investigating this can be from either operating system.


Note that I do NOT have this problem with the older Cruzer Glides (with the amber LED). This is only a problem with the newer blue LED ones.

what's your interest


forum_ban8_5d8c5fd7cf6f7.gif