yandex
loader

please wait

  • James Watson Feb-12-2019 06:45:03 AM ( 1 month ago )

    I'm using node-gyp on Linux with and need to use actions to define custom build steps (note sure whether this is a node-gyp issue or a general gyp issue).

    The documentation seems to suggest that you should specify the command for the build steps as an array of strings, which must get concatenated together at some point to form the command:

    'action': ['python', 'tools/js2c.py', '<@(_outputs)', 'CORE', '<@(core_library_files)'],
    

    As it's Linux, node-gyp is going to generate a makefile for each target in the binding.gyp file, and for actions the custom command will appear in that makefile.

    The problem I'm having is that the command needs to contain an = sign to set an environment variable as part of the command, and I need to chain commands with &&, e.g.:

    export FOO=BAR && do-something-else --option
    

    If I try to specify that as a gyp actions step, I hit various problems. I tried adding each 'word' in the command as a separate array element.

    'action': ['export', 'FOO=BAR', '&&', 'do-something-else', '--option'],
    

    That doesn't work, gyp (or rather the shell the command is passed to) complains that '&&' is not a valid identifier.

    Peeking into the generated makefile, the command has been expanded to this, which explains the shell error:

    export "FOO=BAR" "&&" do-something-else --option
    

    The quotes have been left around the variable assignment and the &&. It's not clear why. I've tried many variations to stop this from happening to no avail. Anything that contains = or & ends up with quotes left around it, which in most cases renders the command syntax invalid.

    Suggestions appreciated.

  • Mike Franklin Feb-12-2019 06:45:54 AM ( 1 month ago )

    The reason this happens is that Gyp considers everything after the first word to be an argument to the command given in the first word so it quotes these and other special characters to prevent the shell interpreting them. I do not think there is any way to prevent it which, as you discovered, makes creating a custom command using a pipeline of shell commands well nigh impossible.

     

Please login

Similar Discussion

Recommended For You