Categories

See More
Popular Forum

MBA (4887) B.Tech (1769) Engineering (1486) Class 12 (1030) Study Abroad (1004) Computer Science and Engineering (988) Business Management Studies (865) BBA (846) Diploma (746) CAT (651) B.Com (648) B.Sc (643) JEE Mains (618) Mechanical Engineering (574) Exam (525) India (462) Career (452) All Time Q&A (439) Mass Communication (427) BCA (417) Science (384) Computers & IT (Non-Engg) (383) Medicine & Health Sciences (381) Hotel Management (373) Civil Engineering (353) MCA (349) Tuteehub Top Questions (348) Distance (340) Colleges in India (334)
See More

biblatex-chicago authordate fullcite problem

Course Queries Syllabus Queries
Max. 2000 characters
Replies

usr_profile.png
Peter Jarvis

User

( 5 months ago )


The following might be a bug, but I'm wondering if anyone knows of a workaround.

I have two bibliography entries with crossref, which I need to print using fullcite in my document. I do not want to print the main bibliographic entry. I am able to do it without a problem in biblatex-chicago. But as soon as I specify authordate I get an error. The error only prints in my log when I have the hyperef package loaded, but regardless there is an error. The error reads pdfTeX warning (dest): name{cite.0@Editorzzz:2002} has been referenced but does not exist, replaced by a fixed one

this is mybib.bib

@incollection{Lxxx:2002,
    Author = {Nxxx Lxxx},
    Crossref = {Editorzzz:2002},
    Title = {This is a story}}

@incollection{Lyyy:2002,
    Author = {Nyyy Lyyy},
    Crossref = {Editorzzz:2002},
    Title = {This is another story}}

@book{Editorzzz:2002,
    Address = {Durham},
    Booktitle = {A Reader of Something},
    Editor = {Nzzz Editorzzz},
    Publisher = {Duke University Press},
    Title = {A Reader of Something},
    Year = {2002}}

This is my preamble tmp.tex

\documentclass[]{article}
\usepackage[authordate,backend=biber]{biblatex-chicago}
\usepackage[]{hyperref}

\bibliography{mybib}

\begin{document}


\fullcite{Lxxx:2002}

\fullcite{Lyyy:2002}

\end{document}

When I do not specify authordate I get this:

Nxxx Lxxx, “This is a story,” in A Reader of Something, ed. Nzzz Editorzzz (Durham: Duke University Press, 2002)

Nyyy Lyyy, “This is another story,” in Editorzzz, A Reader of Something

Which is fine. But when I specify authordate then I get this:

Nxxx Lxxx. 2002. “This is a story”in Editorzzz 2002

Nyyy Lyyy. 2002. “This is another story”in Editorzzz 2002

A full citation is missing for at least one of them. Is there a workaround? I'm working on a syllabus and I have a lot of cross referenced entries but do not want to print the the reader, or main collection since I'm only including the full citation some entries in the collection.

Any ideas?

usr_profile.png
Liza Sain

User

( 5 months ago )


The cross-referenced parent is printed in the bibliography by default. Since you do not invoke \printbibliography references to the parent bibliography item cause the warnings. Normally you can suppress items in the bibliography with the skipbib option, but the style ignores its setting. So I'd consider this a bug.

From the incollection driver defined in chicago-authordate.bbx it is apparent that the text following the in string is generated by the command \bibxrefcite{\thefield{crossref}}. In chicago-authordate.cbx:

\DeclareCiteCommand{\bibxrefcite}
  {\usebibmacro{cite:init}}%\usebibmacro{clearalmostall}} (?)
  {\usebibmacro{cms-in:}%
    \blx@ibidreset% For authordate style
    \usebibmacro{cite}}
  {}
  {}

To fix the missing punctuation/whitespace before the in string and obtain a "fuller" citation you can redefine this in your preamble with:

\makeatletter
\DeclareCiteCommand{\bibxrefcite}
  {\usebibmacro{cite:init}}
  {\newunitpunct% add missing punctuation
   \usebibmacro{cms-in:}%
   \blx@ibidreset%
   \usedriver{}{\thefield{entrytype}}}
  {}
  {}
\makeatother

To obtain shorter subsequent citations to the parent entry, load biblatex-chicago with citetrackerand make use of the \ifciteseen test in \bibxrefcite. For example:

\makeatletter
\DeclareCiteCommand{\bibxrefcite}
  {\usebibmacro{cite:init}}
  {\newunitpunct% add missing punctuation
   \usebibmacro{cms-in:}%
   \blx@ibidreset%
   \ifciteseen
     {\printnames{labelname}\newunit\printfield{title}}
     {\usedriver{}{\thefield{entrytype}}}}
  {}
  {}
\makeatother

You should get in touch with the biblatex-chicago author about the missing punctuation/whitespace and potential for non-existent link targets directly.

what's your interest


forum_ban8_5d8c5fd7cf6f7.gif