Categories

See More
Popular Forum

MBA (4887) B.Tech (1769) Engineering (1486) Class 12 (1030) Study Abroad (1004) Computer Science and Engineering (988) Business Management Studies (865) BBA (846) Diploma (746) CAT (651) B.Com (648) B.Sc (643) JEE Mains (618) Mechanical Engineering (574) Exam (525) India (462) Career (452) All Time Q&A (439) Mass Communication (427) BCA (417) Science (384) Computers & IT (Non-Engg) (383) Medicine & Health Sciences (381) Hotel Management (373) Civil Engineering (353) MCA (349) Tuteehub Top Questions (348) Distance (340) Colleges in India (334)
See More

C# application works on Win 7 But not on XP

Course Queries Syllabus Queries
Max. 2000 characters
Replies

usr_profile.png
Nicola Aley

User

( 5 months ago )


I have built an application in C# and also built a setup for this application. The application on setup works on all Windows 7 machines but doesnt seem to work on any XP machine.

I shall briefly describe what my application does.

The application plays a swf file on startup. The swf file has 3 buttons with separate functions. Basically on clicking these buttons it has to show certain images which are loaded from sqlite.

The problem is that the application loads the swf correctly, the swf plays completely till the end, then at the end where i have placed 3 buttons the click event does not respond to any button. i am guessing this is a problem with FSCommand and the dlls not getting registered correctly

The dlls that i have added to my setup are

  • AxInterop.ShockwaveFlashObjects.dll
  • Interop.shockwaveFlashObjects.dll
  • System.Data.SQLite.dll
  • KP-ImageViewerV2.dll (from codeproject.com)

Also the files present are my manifest file and .config file

I tried registering my Dlls manually using RegSrv32 C:\Interop.ShockwaveFlashObject.dll and also C:\AxInterop.ShockwaveFlashObject.dll The error i get is

The (DllPath and Name Here) was loaded but DllRegisterServer entry point was not found.

The code that i am using to display my swf file is as below

private void axShockwaveFlash1_FSCommand(object sender,AxShockwaveFlashObjects._IShockwaveFlashEvents_FSCommandEvent e)
 {
   string btn = e.command.ToString();
   if (btn == "play")
     {
       try
        {
        frmMain Main = new frmMain();
        Main.Show();
        this.Hide();
        }
        catch (Exception ex) 
        { MessageBox.Show(ex.ToString()); }
      }
      if (btn == "syllabus")
      {
         SQLiteConnectionStringBuilder strbldr = new SQLiteConnectionStringBuilder();
         strbldr.DataSource = @Environment.GetFolderPath(Environment.SpecialFolder.ApplicationData) + "\\TVC E-Excust Customs\\E-ExcustCustoms.s3db";
         SQLiteConnection con = new SQLiteConnection(strbldr.ConnectionString);
         con.Open();
         Syllabus_usageInformation syl = new Syllabus_usageInformation(this);
         SQLiteCommand cmd = new SQLiteCommand("SELECT ImageFiles FROM misc WHERE Name='Syllabus new'", con);
         SQLiteDataReader reader = cmd.ExecuteReader();
         byte[] imageBytes = null;
         while (reader.Read())
         {
          imageBytes = (System.Byte[])reader["ImageFiles"];
         }

         MemoryStream ms = new MemoryStream(imageBytes, 0, imageBytes.Length);
         con.Close();
         syl.kpImageViewer1.OpenButton = false;
         syl.kpImageViewer1.Image = (Bitmap)Image.FromStream(ms,
								 								 
							usr_profile.png
							
Bhanu Gupta

User

( 5 months ago )

Alright PROBLEM SOLVED..there is some problem with .net 4.0. I found this because i searched something on google for my problem, i dont remember the search i did but it returned 2 results!! one of which had a conversation, some VS guy and a user were talking about the problem he faced which was similar to mine. the VS guy agreed that indeed the problem was with 4.0 and that they will rectify the problem. Seems i wasted a lot of time.

what's your interest