Categories

See More
Popular Forum

MBA (4887) B.Tech (1769) Engineering (1486) Class 12 (1030) Study Abroad (1004) Computer Science and Engineering (988) Business Management Studies (865) BBA (846) Diploma (746) CAT (651) B.Com (648) B.Sc (643) JEE Mains (618) Mechanical Engineering (574) Exam (525) India (462) Career (452) All Time Q&A (439) Mass Communication (427) BCA (417) Science (384) Computers & IT (Non-Engg) (383) Medicine & Health Sciences (381) Hotel Management (373) Civil Engineering (353) MCA (349) Tuteehub Top Questions (348) Distance (340) Colleges in India (334)
See More

Windows App Certification Kit hangs

General Tech QA/Testing
Max. 2000 characters
Replies

usr_profile.png
Nicola Aley

User

( 6 months ago )

I have developed windows 10 App and uploaded that to windows store. However, I wanted to apply Windows Certification App Kit. The testing hangs during these two stages;

Direct3D trim after suspend In progress... UTF-8 file encoding In progress...

I don't use any of those features in my app, but I don't understand why it should hang during process?

Thank you!

usr_profile.png
Bhanu Gupta

User

( 6 months ago )

 

I ran into this exact same issue:

"Direct3D trim after suspend In progress... UTF-8 file encoding In progress..."

Problem was that I didn't try to run the Release Version locally first. It didn't run because I used preprocessor directives like so:

public static LicenseInformation licenseInformation = null;

...

#if DEBUG
        ...
        ...
        licenseInformation = CurrentAppSimulator.LicenseInformation;
#else
        licenseInformation = CurrentApp.LicenseInformation;
#endif

"CurrentApp" did cause an exception.. I use code like this now:

#if DEBUG
        ...
        ...
        licenseInformation = CurrentAppSimulator.LicenseInformation;
#else
        try
        {
            licenseInformation = CurrentApp.LicenseInformation;
        }
        catch (Exception)
        {
        } 
#endif

And when working with the licenseInformation somewhere I check if it is not null before I use it...

I also found some other issues (warnings) in my code by using "Run Code Analysis on Solution"..

So in my case it was a problem with my code.

what's your interest


forum_ban8_5d8c5fd7cf6f7.gif